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Summary statement  11 

This study uses an open-source Fiji plugin TrackMate to computationally analyze Drosophila 12 

adult and larval behavioral assays, which does not require programming skills.  13 
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Abstract 14 

Drosophila adult and larvae exhibit sophisticated behaviors that are widely used in development, 15 

synaptic transmission, sensory physiology, and learning and memory research. Many of these 16 

behaviors depend on locomotion, the ability of an animal to move. However, the statistical analysis 17 

of locomotion is not trivial. Here we use an open-source Fiji plugin TrackMate to track the 18 

locomotion of Drosophila adults and larvae. We build optimal experimental setups to rapidly 19 

process recordings by Fiji and analyze by TrackMate. We also provide tips for analyzing non-20 

optimal recordings. TrackMate extracts the X and Y positions of an animal on each frame of an 21 

image sequence or a video. This information allows for generating moving trajectories, calculating 22 

moving distances, and determining preference indices in two-choice assays. Notably, this free-cost 23 

analysis method does not require programming skills.   24 

  25 
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Introduction  26 

Drosophila melanogaster exhibit sophisticated behaviors that are widely used in studies of 27 

development, synaptic transmission, sensory physiology, and learning and memory. Many of these 28 

behaviors depend on locomotion, the ability of an animal to move. The locomotion analysis of 29 

larvae and adult flies is essential to gather insights into how modifications of genetic components 30 

affect animal behaviors and responses to stimuli. The examination of their movement thereby has 31 

become an integral part of such studies leading to the development of tracking systems to provide 32 

a quantitative description of their behaviors (Bellen et al., 2010).  33 

Several tracking systems have been developed to track the locomotion of larvae and adult 34 

flies and generate trajectories (Werkhoven et al., 2019, Branson et al., 2009, Valente et al., 2007, 35 

Straw and Dickinson, 2009, Colomb et al., 2012). However, many methods require programming 36 

skills and/or commercial software to set up and run the tracking systems, which often become 37 

obstacles for researchers to adopt these methods. Other methods require specific experimental 38 

setups to collect data and are challenging to analyze non-optimal recordings. Therefore, it is not 39 

trivial to statistically analyze the locomotion of larvae and adult flies. There is a need to develop 40 

an open-source approach that does not require programming skills but can computationally track 41 

the movement of larvae and adult flies and generate trajectories. Ideally, this method can analyze 42 

non-optimal recordings.  43 

In this study, we use an open-source Fiji plugin TrackMate to achieve this goal. We build 44 

optimal experimental setups to rapidly process and analyze behavioral recordings. We also provide 45 

examples of analyzing non-optimal recordings. TrackMate extracts the X and Y positions of an 46 

animal on each frame. This information allows for generating moving trajectories, calculating 47 

moving distances, and determining preference indices in two-choice assays. Notably, this free-cost 48 

analysis method does not require programming skills. This method is validated by analyzing the 49 

free motion and two-choice thermotactic behavioral discrepancies of wild type and thermoreceptor 50 

mutants in larvae and adult flies.  51 

Results 52 

Using TrackMate to analyze the locomotion of adult flies 53 

We first used TrackMate to analyze the locomotion of adult flies. Since TrackMate recognizes 54 

particles (regions of interest (ROIs)) based on their intensities, background noise signals can be 55 

recognized and mistakenly tracked as ROIs. We suggested maximally diminishing the background 56 
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noise signals by performing the assay on a piece of white paper (Fig. 1A). In our setup, the fly was 57 

covered by a transparent cover that only allowed the fly to walk, not fly. A Styrofoam box was 58 

placed to cover the experimental region to create a featureless environment with dim ambient light 59 

of < 10 lux. A GoPro camera was installed on the ceiling in the Styrofoam box to take time-lapse 60 

pictures (1 picture per second) for 2 minutes. These pictures were then imported into Fiji as an 61 

image sequence and preprocessed. Next, TrackMate was run to track the fly movement, extract its 62 

X and Y positions, generate the trajectory (Fig. 1C), and the moving distance was calculated (Fig. 63 

1D). We found that the warm receptor mutant, Gr28bMB, moved significantly more than wild-type 64 

(wt) flies (Fig. 1C,D; Movie 1).   65 

TrackMate was also used to analyze the two-choice assay. In the two-choice assay, a line 66 

was drawn to separate different temperatures (Fig. 1E). According to the X position of the line 67 

and the X position of the fly on each frame, the time the fly spent in each temperature zone was 68 

calculated and the preference index was determined. While wt flies avoided 31°C and preferred 69 

25°C, Gr28bMB did not show preference between 25°C and 31°C (Fig. 1F). This result is consistent 70 

with previous reports (Ni et al., 2013, Simões et al., 2021, Budelli et al., 2019). Moreover, Gr28bMB 71 

also moved more than wild-type (wt) flies in this condition (Fig. 1D,E; Movie 1).   72 

An optogenetic assay was also analyzed by TrackMate. The optogenetic tool used in this 73 

study was the red light-shifted channelrhodopsin CsChrimson. When bound to all-trans retinal 74 

(ATR), CsChrimson is activated by the red light to depolarize cells (Klapoetke et al., 2014). To 75 

create the dark and red-light environments, a red-light source was placed on the ceiling in the 76 

Styrofoam box and half of the transparent cover was covered by black tape (Fig. 1B). Of note, the 77 

red light must not be directly above the cover (See the section of Using TrackMate to analyze 78 

nonoptimal recordings and Fig. 3). We suggested installing the GoPro camera in the middle of the 79 

Styrofoam box, the light source on its left, and the experimental region at the right of the Styrofoam 80 

box (Fig. 1B). The recording procedure and analysis method were similar to the two-choice assay. 81 

Heating Cells (HCs) in aristae drive warm avoidance (Gallio et al., 2011, Budelli et al., 2019, Ni 82 

et al., 2013). Flies expressing CsChrimson in HCs avoided red light with dietary ATR (Fig. 1G,H; 83 

Movie 1). Without ATR, HCs weren’t activated and did not guide flies to avoid the red light. This 84 

was validated by the observation that flies often traveled from the dark zone to the red-light zone 85 

and thus the red-light zone had multiple tracks (Fig. 1G; Movie 1).  86 

 87 
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Using TrackMate to analyze the larval locomotion  88 

Next, we used TrackMate to track the larval movement and analyzed the larval two-choice 89 

thermotactic assay. The larva was allowed to move on 3% agar gel. To diminish the background 90 

noise signals and increase contrast, a sheet of matte black poster was placed under the gel and 91 

ambient light was dimed to under 10 lux. A GoPro camera was placed above the gel to record the 92 

larval movement for 2 min. For the two-choice assay, the larva was released in the middle of two 93 

temperatures (Fig. 2A). The 2-min video was imported into Fiji and preprocessed. For the two-94 

choice assay, a line was drawn to separate different temperatures. Of note, this line must not pass 95 

the moving path of the larva (Fig. 2E). TrackMate was then used to track the larval movement and 96 

generate its trajectory (Fig. 2C,E). TrackMate also extracted X and Y positions of the larva on 97 

each frame to calculate its moving distance and preference index (Fig. 2D,F).  98 

IR93a is a subunit of the cool receptor in dorsal organ cool cells (DOCCs) and guides larvae 99 

to avoid cool temperatures (Knecht et al., 2016). In a unique temperature environment, moving 100 

distances of wt and Ir93aMI larvae were similar (Fig. 2C,D; Movie 1). However, Ir93aMI larvae 101 

moved significantly less than wt larvae in a two-temperature environment (Fig. 2D,E; Movie 1). 102 

Regarding preference indices, wt larvae preferred 18°C (Fig. 2E,F; Movie 1). This is consistent 103 

with previous reports (Kwon et al., 2008, Kwon et al., 2010, Shen et al., 2011). The Ir93aMI larvae 104 

had no preference between 18°C and 25°C, suggesting IR93a is required for choosing the optimal 105 

temperature within this temperature range (Fig. 2E,F; Movie 1).  106 

The larval optogenetic assay must be performed under an infrared condition while avoiding 107 

light glares. The red-light intensity should be even across the region where the larva travels (Fig. 108 

2B). The recording procedure and analysis method were similar to the free motion assay. Larvae 109 

expressing CsChrimson in DOCCs showed aversive behaviors under red light with dietary ATR, 110 

such as the pause of run, which in turn led to the decrease of the run speed (Fig. 2G,H) (Tyrrell et 111 

al., 2021). These aversive behaviors reflected the cool avoidance driven by DOCCs and were not 112 

observed in the group without ATR (Fig. 2G,H).  113 

 114 

Using TrackMate to analyze non-optimal recordings 115 

If behavioral recordings are available and computational analysis is required, TrackMate is an 116 

option. The analysis process may take longer if the recordings contain background noise signals. 117 

Fig. 3A showed a setup for optogenetics previously used in the lab (Tyrrell et al., 2021). The light 118 
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source was placed under an agar plate so the light source and light glares were recorded (Fig. 3A). 119 

After being gray scaled, the larva was detected but a significant amount of background noise 120 

signals were also shown (Fig. 3B; the new setup had a cleaner background shown in Fig. 2G). We 121 

suggested cropping the video and using the smallest possible region for analysis. Fiji parameters, 122 

such as background, brightness, and contrast, must be adjusted to diminish background noise 123 

signals. In most cases, not all background noise signals could be avoided (circle in Fig. 3B). 124 

TrackMate parameters, including LoG detector, filters on spots, simple LAP tracker, and filters on 125 

tracks, must also be optimized to detect the larva in most frames (>99%) and maximally decrease 126 

noise signals. Finally, the All Spots statistics.csv file must be carefully checked to ensure all ROIs 127 

related the larva, not noise signals. The colorful track suggested the larva was not detected or 128 

counted more than once on some frames so that multiple tracks were generated (Fig. 3B). Although 129 

having taken longer to process and analyze, these non-optimal recordings found similar results that 130 

DOCC expression of CsChrimson drove aversive behaviors (Fig. 3C).  131 

 Discussion 132 

In this study, we apply an open-source Fiji plugin TrackMate to track the locomotion of adult flies 133 

and larvae in image sequences and videos and generate trajectories. Since TrackMate extracts the 134 

X and Y positions of an animal on each frame, it is used to analyze preference indices in two-135 

choice assays, in which the separating line can be defined as X or Y positions. In addition, 136 

TrackMate can be used to analyze non-optimal recordings with strong background noise signals.   137 

Clean background facilitates the analysis. TrackMate detects ROIs – flies or larvae – based 138 

on their intensities. It cannot distinguish ROIs from background noise signals if they have similar 139 

sizes and/or intensities. Thereby, noise signals cause aberrant trajectories and require researchers 140 

to adjust TrackMate parameters to avoid these signals or check the All Spots statistics.csv file to 141 

delete information for noise signals in the file. We provide easy ways to get clean backgrounds – 142 

a piece of white paper and matte black poster sheet can significantly decrease background noise 143 

signals in adult and larval behavioral assays, respectively. 144 

 TrackMate extracts the X and Y positions of the ROI on each frame. According to this 145 

information, the moving distance is determined, calculated in pixels. If moving distances from two 146 

experiments need comparing, it is essential to convert the pixel distance to the actual distance. 147 

Moreover, the camera position and image size must be kept constant from trial to trial to avoid the 148 
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conversion. To keep the analysis simple and accurate, we recommend using the same setup to 149 

perform all experiments that need comparing. 150 

 TrackMate can analyze data recorded in image sequences and videos. In this study, we use  151 

time-lapse images to record adult behaviors and videos to record larval behaviors. Thereby, 152 

analysis approaches for both recording methods have been shown. In videos, every second contains 153 

24-30 frames; their high temporal resolutions can resolve more behavioral details. When 154 

calculating moving distances and preference indices, high temporal resolutions are not necessary. 155 

In this case, time-lapse images become a better choice because they contain less data and take a 156 

shorter time to analyze. However, the time-lapse image resolution of the GoPro cannot distinguish 157 

the larva from the background and videos are used for larval assays instead. When performing the 158 

larval optogenetic assay, we find it is easier to track the larva under infrared conditions. Of note, 159 

regular cameras don't work under infrared conditions – the internal infrared filter needs to be 160 

removed and replaced by an 830 nm long-pass filter. 161 

 Based on trajectories, researchers can observe whether an animal runs or turns. But 162 

TrackMate may not be used to analyze more complex behaviors, such as larval head sweeping. 163 

We set a relatively large blob diameter to make TrackMate recognize the adult fly or larva as a 164 

single ROI. If using a relatively small blob diameter, TrackMate often detects the animal as 165 

multiple ROIs. But the localization of each ROI cannot be predicted; in other words, TrackMate 166 

cannot be used to recognize different parts of an animal, such as the head or tail. Thereby, it is 167 

challenging to use TrackMate to analyze more complex behaviors.   168 

 169 

Materials and methods 170 

Drosophila strains 171 

CS and WCS were used as wild-type controls for larval and adult behavioral assays, respectively. 172 

The following flies were previously described: UAS-CsChrimson (Klapoetke et al., 2014), Ir93aMI 173 

(Knecht et al., 2016), Ir93a-Gal4 (Sanchez-Alcaniz et al., 2018), Gr28bMB  (Ni et al., 2013), HC-174 

Gal4 (Gallio et al., 2011).  175 

 176 

Adult behavioral assays 177 

Flies were raised at 25°C under 12-hour light/12-hour dark cycles and were 3-7 days old when 178 

tested. For the two-choice thermotactic assay, two steel plates on different hot plates were aligned 179 
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so that the steel plate boundaries were brought together. Hotplate temperatures were adjusted 180 

allowing the surface of the steel plates to be 25±1°C and 31±1°C, respectively. For the free 181 

movement behavioral assay, a steel plate was placed on a hot plate and its surface temperature was 182 

adjusted to 25±1°C. The plates were sprayed with dH2O and a plastic sheet protector was placed 183 

on top. Excess moisture was removed by Kimwipe. A white paper was placed on top of the plastic 184 

sheet protector to reduce background noise signals. A clear plastic cover was covered with 185 

SigmaCote to prevent the fly from walking on the plastic cover and was placed on top of the white 186 

sheet so that it was divided evenly on the steel plate boundary creating the experimental chamber. 187 

The temperature was monitored before each trial using a surface temperature probe (80PK-3A, 188 

Fluke) and thermometer (Fisherbrand Traceable Big-Digit Type K Thermometer). A wild-type 189 

control was run at the beginning of every data collection session. For the experiment, a fly of 190 

known sex was placed under the plastic cover and a Styrofoam box was placed to cover the 191 

experimental area to remove light and allow for the experiment to be conducted in dim ambient 192 

light (<10 lux). The flies were given 2 minutes to acclimate on the 25±1°C side. A HERO8 GoPro 193 

was positioned at the top of the Styrofoam box (8 inches in height). The motion of the fly was 194 

recorded by taking a time-lapse photo every second for 120 seconds.  195 

Adult optogenetic assays were recorded by a HERO8 GoPro. Half of a clear plastic cover 196 

was covered with black tape. A piece of white paper was put under the cover to reduce noise from 197 

the background. A Styrofoam box was used to cover the experimental area. A HERO8 GoPro was 198 

mounted at the top of the Styrofoam box. On one side of the GoPro, a red-light source (Tyrrell et 199 

al., 2021) was attached. The plastic cover was placed on the other side of the GoPro to avoid the 200 

glare that is caused by the direct light. A single fly of known sex was pipetted under the plastic 201 

cover and given 2 minutes to acclimate. The light source was turned on and the motion of the fly 202 

was recorded by taking a time-lapse photo every second for 60 seconds. Positive and negative 203 

controls were run at the beginning of every data collection session. 204 

 205 

Larval behavioral assays 206 

Flies were maintained at 25°C under 12-hour light/12-hour dark cycles. Larvae were collected as 207 

described with some modifications (Tyrrell et al., 2021). Briefly, each vial contained 20-45 males 208 

and females. These flies were given at least 24 hours to recover from CO2 before being tapped 209 

over to new vials containing yeast granules. They were allowed 4 to 8 hours to lay eggs and, on 210 
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day 4, larvae were collected using 10 mL of 20% w/v sucrose solution. Larvae were collected after 211 

20 minutes and thoroughly washed three times with diH2O. Larvae were then plated on a 60 mm 212 

tissue culture dish (Corning) with about 13 mL of 3% room temperature (about 20°C) agar gel and 213 

given 5 to 10 minutes to recover from the washing process and acclimate to the agar.  214 

The two-choice assay was performed as described with some modifications (Tyrrell et al., 215 

2021). Two steel plates on different hot plates were separated by 1/16 inches (the release zone). 216 

For the free movement behavioral assay, a steel plate was placed on a hot plate and its surface 217 

temperature was adjusted to 18±1°C. A matte black poster sheet was placed on top of steel plates. 218 

A plastic sheet protector was placed on the poster sheet to prevent warping from moisture. A 3% 219 

agar gel (10 X 9.5 inched) was placed on the plastic protector sheet and evenly positioned at the 220 

release zone. The surface temperature was 18±1°C on one side of the gel and 25±1°C on the other. 221 

The release zone was labeled at the top and bottom of the gel. The temperature was monitored 222 

before each trial using a surface temperature probe (80PK-3A, Fluke) and thermometer 223 

(Fisherbrand Traceable Big-Digit Type K Thermometer). A wild-type control was run at the 224 

beginning of daily experiments. Water was gently sprayed between trials to moisten the agar 225 

surface. A larva was placed at the release zone and given 2 minutes to wander. The experiment 226 

was conducted at dim ambient light (<10 lux). A GoPro was suspended above the gel (10.5 in) to 227 

record the motion of the larva for each trial. 228 

Larval optogenetic assays were recorded by a Sony HDR-CX405 camcorder with the 229 

internal infrared filter removed and an 830 nm long-pass filter (FSQ-RG830, Newport) installed. 230 

A 3% agar gel was cut to 3 X 5 inches. A sheet of a matte black poster was placed under the gel 231 

to reduce background noise signals and infrared light (4331910725, Amazon) was used to visualize 232 

the larvae. Two red-light sources (Tyrrell et al., 2021) were attached 10 inches above the gel at a 233 

45° angle on both sides of the gel such that the light intensity was even throughout the gel (~3 234 

klux) and no glare was created. A third red-light source was placed in a box outside the 235 

experimental setup but within the view of the camera to serve as an indicator to record when red 236 

lights were on or off. Larvae were collected and prepared for the assay as detailed above except 237 

that they were kept in food with 40 µM all trans-retinal (ATR, Sigma-Aldrich) and in dark for 72 238 

hours. An individual larva was placed on the agar gel and given 30 seconds to acclimate. For the 239 

recording, the larva was given 30 seconds to wander followed by 3 cycles of 5 seconds shone 240 

under red lights and a 15 second recovery period.  241 
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 242 

Preprocessing photos for adult behavioral assays 243 

The individual photos for each trial were combined into a single file using Fiji and converted to 8-244 

bit grayscale (File > Import > Image Sequence function; boxes of Convert to 8-bit Grayscale and 245 

Sort names numerically were selected) (Schindelin et al., 2012). For two-choice and optogenetic 246 

assays, the Rotate feature (Image > Transform > Rotate) was used to rotate images until the steel 247 

plate dividing line or tape line was shown as completely vertical. A black line was drawn along 248 

the steel plate boundary to separate the two steel plates (temperatures) using the draw function 249 

(Edit > Draw) and applied to all images. Then, for all the assays, the Crop feature (Image > Crop) 250 

was used to only keep the experimental area. Next, backgrounds were subtracted from all images 251 

(Process > Subtract Background; set rolling ball radius of 20.0 pixels; the box of light background 252 

was selected). The brightness/contrast was adjusted to enhance the difference between the dark fly 253 

and the white background (Image > Adjust > Brightness/Contrast). Lastly, the threshold was set 254 

to the automatic suggested setting (Image > Adjust > Threshold; Default and B&W settings were 255 

chosen, the box of Don’t reset range was selected). In the Convert Stack to Binary box, the method 256 

was set to default, background was set to light, and the box corresponding to calculate threshold 257 

for each image was selected. The preprocessed image was then saved as a TIFF (File > Save as > 258 

TIFF) for analysis.  259 

 260 

Preprocessing videos for larval behavioral assays 261 

Videos were converted to .avi and the resolution was decreased to 760x480 by Any Video 262 

Converter 9 (AnvSoft). They were then uncompressed by the command line tool ffmpeg to be 263 

compatible with Fiji.  264 

Videos were imported to Fiji and converted to 8-bit grayscale (File > Import > AVI; the 265 

box of Convert to Grayscale was selected). For two-choice assays, the Rotate feature (Image > 266 

Transform > Rotate) was used to rotate images such that the marker line indicating release zone 267 

was completely vertical. Along the release zone, white lines were drawn at the top and bottom of 268 

the larval motion zone; they must be close to but not in the larval motion zone and applied to the 269 

first image only (Edit > Draw). Then, an area that was slightly larger than the larval motion zone 270 

and included the top and bottom white lines was selected and the Crop feature (Image > Crop) was 271 

applied for all images. Next, background was subtracted from all images (Process > Subtract 272 
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Background; rolling ball radius of 50.0 pixels). Finally, the brightness/contrast was adjusted to 273 

enhance the difference between the white larva and the black background (Image > Adjust > 274 

Brightness/Contrast; set Maximum to the left and applied; then set Contrast to the right and 275 

applied). The preprocessed image was saved as a .avi file (File > Save as > AVI) for analysis.  276 

 277 

TrackMate Analysis 278 

TrackMate in Fiji was used to analyze the moving distances and preference/avoidance indices 279 

(Tinevez et al., 2017). Preprocessed .tif files or .avi files were opened by Fiji and TrackMate was 280 

run. In the box of the LoG Detector, we suggested to adjust parameters of Estimated blob diameter, 281 

Threshold, and Median filter. For adult flies, set Estimated blob diameter to 27.0 – 40.0 pixels, 282 

Threshold to 1.0 - 2.5, and select Median filter. For larvae, set Estimated blob diameter to about 283 

10.0 pixels, Threshold to 1.0, and deselect Median filter. In the box of Set filters on spots, filters 284 

could be used to remove aberrant ROIs by choosing the X and Y region for ROIs as well as the 285 

Quality of the ROIs found. Alternatively, aberrant ROIs can be removed manually from the 286 

resulting .csv file. In the box of the Simple LAP tracker, the Linking max distance, the Gap-closing 287 

distance, and the Gap-closing max frame gap were suggested to adjust.  For adult flies, set the 288 

Linking max distance, the Gap-closing distance to 1500 pixels and the Gap-closing max frame gap 289 

to 2. For larvae, set the Linking max distance, the Gap-closing distance to 25 pixels and the Gap-290 

closing max frame gap to 2. In the box of Select an action, Export all spot statistics was selected 291 

and Execute was clicked. The All Spots statistics file was cross-referenced with the spot detection 292 

in Fiji to ensure only one spot was marked for each time stamp, with erroneous duplicates and/or 293 

aberrant ROIs deleted. Then the All Spots statistics was saved as .csv files. 294 

The moving distance from frame n to the next frame was calculated through the following 295 

formula: 296 

∆	𝐷𝑖𝑠𝑡𝑎𝑛𝑐𝑒 = 	,(𝑥/01 − 𝑥/)4 + (𝑦/01 − 𝑦/)4 297 

The Preference Index (PI) or Avoidance Index (AI) was calculated by using the X position. 298 

The PI for the two-choice assay was calculated based on the time the animal spent in each 299 

temperature zone and using the following formulas: 300 

For adults: 301 

PI = 	
(time	in	25°C	) − (time	in	31°C	)	

Total	time  302 
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For larvae: 303 

PI = 	
(time	in	18°C	) − (time	in	25°C	)	

Total	time  304 

 305 

The AI for the adult optogenetic assay was calculated based on the time a fly spent in dark or red 306 

light and using the following formulas: 307 

AI = 	
(time	in	dark) − (time	in	red	light	)	

Total	time  308 

 309 

Statistical analysis: 310 

Statistical details of experiments are mentioned in the figure legends. The normality of 311 

distributions was assessed by the Shapiro-Wilk W test (p ≤ 0.05 rejected normal distribution). 312 

Statistical comparisons of normally distributed data were performed by the Welch’s t test. For data 313 

that did not conform to a normal distribution, statistical comparisons were performed by the Mann-314 

Whitney test. Data analysis was performed using GraphPad Prism 9.  315 

  316 
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 387 
Fig 1. Use TrackMate to analyze the adult behavior. (A,B) Setups for the single-fly two-choice 388 

thermotactic (A) and optogenetic assay (B). The setup for the free motion assay is similar to the 389 

two-choice assay but is performed on a single plate with a unique temperature (25°C). (C) wt and 390 

Gr28bMB trajectories in the free motion assay. (D) Moving distances of indicated genotypes and 391 

conditions. n = 15; data represent mean ± SEM; * p < 0.05, ** p < 0.01; Welch’s test for the free 392 

motion assay and Mann-Whitney test for the two-choice assay. (E) wt and Gr28bMB trajectories in 393 

the two-choice assay. (F) Preference indices of indicated genotypes. n = 7 - 11; data represent 394 

mean ± SEM; ** p < 0.01; Mann-Whitney test. (G) Trajectories of HC-Gal4;UAS-CsChrimson 395 

(HC>CsChrimson) flies with or without dietary retinal (ATR) in the optogenetic assay. Of note, 396 
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two trajectories (blue and red) are shown in the left panel, suggesting the fly enters the red-light 397 

zone twice. (H) Avoidance indices of HC>CsChrimson flies with or without dietary retinal (ATR). 398 

n = 15; data represent mean ± SEM; **** p < 0.0001; Mann-Whitney test.   399 
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 400 
Fig 2. Use TrackMate to analyze the larval behavior. (A,B) Setups for the single-larva two-401 

choice thermotactic (A) and optogenetic assay (B). The setup for the free motion assay is similar 402 

to the optogenetic assay but is performed in the room light. (C) wt and Ir93aMI trajectories in the 403 

free motion assay. (D) Moving distances of indicated genotypes and conditions. n = 15 - 30; data 404 

represent mean ± SEM; * p < 0.05; Welch’s test for the free motion assay and Mann-Whitney test 405 

for the two-choice assay. (E) wt and Ir93aMI trajectories in the two-choice assay. (F) Preference 406 

indices of indicated genotypes. n = 30; data represent mean ± SEM; ** p < 0.01; Mann-Whitney 407 

test. (G) The locomotion of an Ir21a-Gal4;UAS-CsChrimson (Ir21a>CsChrimson) larva with 408 
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ATR in the optogenetic assay. Upper: the video is gray scaled and cropped by Fiji. Lower: the 409 

recording is preprocessed by Fiji and analyzed by TrackMate. (H) The relative speed of 410 

Ir21a>CsChrimson larvae with or without ATR. Relative speed is defined as the moving speed 411 

during red light on divided by the moving speed during light off. n = 15; data represent mean ± 412 

SEM; ** p < 0.01; Mann-Whitney test.  413 
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 414 
Fig 3. Use TrackMate to analyze non-optimal recordings. (A) A previous setup of the single-415 

larva optogenetic assay, in which light glares and other background noise signals are detected. (B) 416 

The locomotion of an Ir21a>CsChrimson larva with dietary retinal (ATR). Upper: the video is 417 

gray scaled and cropped by Fiji. Lower: the recording is preprocessed by Fiji and analyzed by 418 

TrackMate. The trajectory is shown in rainbow colors. (C) The relative speed of 419 

Ir21a>CsChrimson larvae with or without ATR. n = 3; data represent mean ± SEM; * p < 0.05; 420 

Welch’s test.  421 
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Movie 1. Representative trajectories of Drosophila adult and larval behaviors. The following 422 

behaviors are included: the wt and Gr28bMB single-fly free movement and two-choice thermotactic 423 

assays, HC>CsChrimson single-fly optogenetic assay (without and with dietary ATR), and wt and 424 

Ir93aMI single-larva free movement and two-choice thermotactic assays.  425 

 426 
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